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DEPARTMENT OF MECHANICAL ENGINEERING  

 

VISION 

 

The Mechanical Engineering Department endeavors to be recognized globally for outstanding 

education and research leading to well qualified engineers, who are innovative, entrepreneurial 

and successful in advanced fields of mechanical engineering to cater the ever changing 

industrial demands and social needs. 

 

MISSION 

The Mechanical Engineering program makes available a high quality, relevant engineering 

education. The Program dedicates itself to providing students with a set of skills, knowledge and 

attitudes that will permit its graduates to succeed and thrive as engineers and leaders. The 

Program strives to: 

 

 Prepare the graduates to pursue life-long learning, serve the profession and meet 
intellectual, ethical and career challenges. 

 Extend a vital, state-of-the-art infrastructure to the students and faculty with 
opportunities to create, interpret, apply and disseminate knowledge. 

 Develop the student community with wider knowledge in the emerging fields of 
Mechanical Engineering. 

 Provide set of skills, knowledge and attitude that will permit the graduates to succeed 
and thrive as engineers and leaders. 

 Create a conducive and supportive environment for all round growth of the students, 
faculty & staff 

 

PROGRAM EDUCATIONAL OBJECTIVES 

 

 1. Prepare the graduates with a solid foundation in Engineering, Science and Technology for 

a successful career in Mechanical Engineering. 

 2. Train the students to solve problems in Mechanical Engineering and related areas by 

engineering analysis, computation and experimentation, including understanding basic 

mathematical and scientific principles. 

3. Inculcate students with professional and ethical attitude, effective communication skills, 

team work skills and multidisciplinary approach 

 4. Provide opportunity to the students to expand their horizon beyond mechanical engineering 

5. Develop the students to adapt to the rapidly changing environment in the areas of 

mechanical engineering and scale new heights in their profession through lifelong learning 
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NOTES TO REMEMBER WHEN WORKING IN AutoCAD 
 

1. When using an AutoCAD command, you MUST read the prompt line and 
respond as needed 

 
 

2. In a prompt, the CAPITALIZED letter(s) of an option are typed short-cuts for 
that option. Information typed on the prompt line is not case-sensitive. 

 

3. To exit a command and return to a Command: prompt, press the 
Esc (Escape) key. 

 

4. In command prompts, AutoCAD's default selection for the prompt appears 
between the less than and more than symbols (< >). If you press 
the Enter key without typing a different option on the prompt line, the 
default option is selected. 

 

EXAMPLE: In a prompt for the Circle command, which reads: 
3P/2P/TTR/ <point>: 
If no other option is selected, AutoCAD assumes that you will give it a 
location for the center of the circle. If you want to use any other option 
(2P, 3P, or TTR), you must type the option on the prompt line. 

 

5. When AutoCAD asks you to indicate a location for an object, the default 
method of selection is a mouse pick. If you accidentally click your left 
mouse button while the cursor is in the drawing area, the object will be 
placed where the cursor was located when you clicked the mouse button. 

 

6. Help files of AutoCAD are the best resource for reference. To open it from 
AutoCAD use Help Menu. 

 
7. Save often to avoid losing your work or you WILL regret it. 
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A quick summary of the basic AutoCAD commands used. 
 

Tool bars are also used. Right click in an empty toolbar area to configure. 
 

Command line: Key shortcut: Pull down menu: 

CLOSE 
 

File > Close 
UNITS  Format > Drawing Setup… 
LIMITS  Format > Drawing Limits 
GRID F7 Format > Drafting Settings… 
SNAP F9 Format > Drafting Settings… 
ZOOM Z  

 Esc  

SAVEAS  File > Save as… 
LINE  Draw > Line 
COORDS   

SPLINE  Draw > Spline 
ERASE  Modify > Erase 
TRIM  Modify > Trim 
OFFSET  Modify > Offset 
EXTEND  Modify > Extend 
OSNAP F3  

LA   

XLINE  Draw > Construction Line 
LTSCALE   

PROPERTIES  Modify > Properties 
MOVE  Modify > Move 
BHATCH  Draw > Hatch 
BLOCK  Draw > Block > Make 
INSERT  Insert > Block… 
DIMSTYLE  Format > Dimension Style… 
MTEXT  Draw > Text 
VPORTS  View > Viewports 
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Ex. No: 1 

Date: 
 

Fig - 1 

 
The following is a list of all the commands required to complete Ex.No.1. Press the F2 key to 
see your input. (Press F2 to close the text screen). 

 
Remember to press ENTER after entering each co-ordinate point. 

 
Command: l LINE 

From point: 1,1 

Specify next point or [Undo]: 4.1,1 

Specify next point or [Undo]: 4.5,2.2 

Specify next point or [Close/Undo]: @2.3,0 

Specify next point or [Close/Undo]: @1.4<30 

Specify next point or [Close/Undo]: @0,2.1 

Specify next point or [Close/Undo]: @1.6<120 

Specify next point or [Close/Undo]: @-1.3,0 

Specify next point or [Close/Undo]: @0,-1.4 

Specify next point or [Close/Undo]: @2.2<135 

Specify next point or [Close/Undo]: @-1,0 

Specify next point or [Close/Undo]: @1.5<225 

Specify next point or [Close/Undo]: @-1,0 

Specify next point or [Close/Undo]: @2.3<-60 

Specify next point or [Close/Undo]: 1,1 
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Ex. No: 2 

Date: 
 

Fig - 2 

 

Hint for Fig.2 
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Ex. No: 3 

Date: 
 

 

 

 

 
Fig - 3 
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Ex. No: 4 

Date: 
 

 

 

 

Fig - 4 
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Ex. No: 5 

Date: 
 

 

 

 

 

 

 

Fig - 5 
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MACHINE DRAWING 

 

Ex. No: 6 KNUCKLE JOINT 

Date: 

Draw Full sectional front view (Fig 6) of the knuckle Joint 

 
PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 

3. Use F3 key (OSNAP command) .From the dialog box, select end point, mid point etc. 
4. By using F8 key, the ortho is ON. 

5. From the UCS (User Co-ordinate System) dialog box select required view. 

6. Draw the different parts of Knuckle joint by using draw and edit commands. 
7. By using move command, assemble all parts. 

8. By using hatch command, the required portion of drawing is hatched. 
 

 

 
 

 

Fig 6 
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Ex. No: 7 BUSHED BEARING 

Date: 

Draw the Full Sectional Front View (Fig 7) of the BUSHED BEARING 

 
PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 
3. Use F3 key (OSNAP command) .From the dialog box, select end point, midpoint etc. 

4. By using F8 key, the ortho is ON. 
5. From the UCS (User Co-ordinate System) dialog box select required view. 

6. Draw the different parts of bushed bearing by using draw and edit commands. 

7. By using move command, assemble all parts. 
8. By using hatch command, the required portion of drawing is hatched. 

 

 
 

 

 

Fig 7 
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C++ PROGRAM: – 
 

OTTO CYCLE EFFICIENCY 

Ex. No: 8 

Date: 

Program: 

#include<iostream.h> 

#include<conio.h> 

#include<math.h> 

#include<iomanip.h> 

 

void main() 

{ 

 

clrscr(); 

float cr,p1,p2,p3,p4,t1,t2,t3,t4,q1,eff; 

 

cout<<"\nEnter 

cin>>cr; 

the Compression ratio (cr) "; 

cout<<"\nEnter 

cin>>p1; 

the initial pressure(p1)in bar"; 

 

cout<<"\nEnter 

 

the 

 

initial Temperature (t1) in 

Kelvin"; 

cin>>t1; 

  

cout<<"\nEnter 

cin>>q1; 

the Heat Supplied (q1) kJ/kg "; 

 

cout<<"\n*****OTTO CYCLE*********\n"; 

p2=pow(cr,1.4)*p1; 

t2=pow(cr,1.4-1)*t1; 

t3=q1/0.718+t2; 
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C 

C++ PROGRAM: – 
 

OTTO CYCLE EFFICIENCY 

Ex. No: 8 

Date: 

Aim: 
An engine working on the Otto cycle is supplied with air at 0.1MPa, 

35oC. The compression ratio is 8. Heat supplied is 2100KJ/Kg. K. To write a 

program in C++ to calculate the maximum temperature, maximum pressure and 

efficiency of the cycle. (For air, Cv = 0.718 kJ/kg.K, Cp = 1.005 kJ/kg.K 

and R = 0.287kJ/kg.K. 
 

Given Data: 
P1 = 0.1MPa = 1bar, T1 = 35oC = 308 K, CR = 8, 

Q1 = 2100kJ/kg K,Cv = 0.718 kJ/kg K, Cp = 1.005 kJ/kg K 

and R = 0.287 kJ/kg K. 

 

Usage of Formula: 

P  rk  * P T  rk  1 *T T  
Q1 

 T 
 

2 1 , 2 1 , 3 2 , 
v 

P  
T3 * P P  1 




  * P T 

 

 1 
 1 

  *T 
 

2 , 4 

2  rk 
3 , 4 

 rk  
3 ,

 

  1 
1 

 
 

rk  1 

where, 

rk = Compression ratio,  = Specific heat ratio = 1.4 
 

Display: 

 3 
T 



15  

p3=(t3/t2)*p2; 

p4=pow(1/cr,1.4)*p3; 

t4=pow(1/cr,1.4-1)*t3; 

eff=1-1/pow(cr,1.4-1); 

cout<<"\nPressure: \n"; 

cout<<"\n\t P1="<<setprecision(2)<<p1<<"bar"; 

cout<<"\n\t P2="<<setprecision(2)<<p2<<"bar"; 

cout<<"\n\t P3="<<setprecision(2)<<p3<<"bar"; 

cout<<"\n\t P4="<<setprecision(2)<<p4<<"bar"; 

cout<<"\nTemperature:\n"; 

cout<<"\n\t t1="<<setprecision(2)<<t1<<"Kelvin"; 

cout<<"\n\t t2="<<setprecision(2)<<t2<<"Kelvin"; 

cout<<"\n\t t3="<<setprecision(2)<<t3<<"Kelvin"; 

cout<<"\n\t t4="<<setprecision(2)<<t4<<"Kelvin"; 

cout<<"\nThe efficiency of the cycle = 

"<<setprecision(2)<<eff*100<<"%"; 

 

getch(); 

} 
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C++ PROGRAM: – 
 

COMPRESSOR DIMENSIONS 

Ex. No: 9 

Date: 

Program: 

#include<iostream.h> 

#include<conio.h> 

#include<math.h> 

 

void main() 

{ 

 

clrscr(); 

 

float fad,p1,p2,n,N,vc,vs,y,eff, 

volume,vol,dia,stroke; 

 

cout<<"\n**** COMPRESSOR DIMENSIONS ****\n"; 

 

cout<<"\nEnter the value of air delivered:"; 

cin>>fad; 

 

cout<<"\nEnter Initial pressure and Compressed 

pressure in bar:"; 

cin>>p1>>p2; 

 

cout<<"\nEnter the speed in rpm:"; 

cin>>N; 

 

cout<<"\nEnter Vc and Vs value :"; 

cin>>vc>>vs; 

 

cout<<"\nEnter L/D ratio:"; 

cin>>y; 

 

cout<<"\nEnter the n value:"; 

cin>>n; 
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



C++ PROGRAM: – 
 

COMPRESSOR DIMENSIONS 

Ex. No: 9 

Date: 

Aim: 

To write a program in C++ to determine the diameter and stroke length of 

the compressor. 

 
The parameters are 

1) The Free Air Delivered (FAD) is 150 m3/min. 

2) Initial pressure is 1 bar 

3) Compressed pressure is 8 bar 

4) The speed of compressor is 300 rpm 

5) Clearance volume is 1 m3 

6) Swept volume is 16 m3 

7) L/D ratio is 1.5 

8) n = 1.3 

 

Given Data: 
FAD = 150 m3/min., P1 = 1bar, P2 = 8bar, N = 300 rpm, Vc = 1m3, 

Vs = 16m3, n(specific heat ratio) = 1.3 and L/D = 1.5. 
 

Usage of Formula: 
 1 

vc  p2  n 



 

output FAD 
 

 

FAD 
 

  1  
vs 





p1 

 1
 , 
 


Input 

 ,V (volume) 
V * N  * N 

1  2 3 4 *V  4 *V  3
 

V (volume)  D 
4 

L, D  

 , D(diameter)    

 


V = п/4 D2L, L=1.5D 
 

D3 = 
4 XV 

 

 

1.5X


D = 
 4V 

 
1/3  

1.5X 



 

3      
4 *V 



, 
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eff=1-((vc/vs)*(pow(p2/p1,1/n)-1)); 

Volume=fad/(eff*N); 

vol=(volume*4)/(y*3.141); 

dia=pow(vol,0.333); 

stroke=y*dia; 

 

cout<<"\nCOMPRESSOR DIMENSIONS:\n"; 

cout<<"\nDiameter of the compressor is "<<dia<<"m"; 

cout<<"\nStroke of the compressor is "<<stroke<<"m"; 

getch(); 

} 

 

Display: 
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MATLAB 

MATLAB, developed by Math works Inc., is a software package for high performance 

numerical computation and visualization. MATLAB provides an interactive 

environment with hundreds of reliable and accurate built-in mathematical functions. 

These functions provide solutions to a broad range of mathematical problems including 
matrix algebra, complex arithmetic, linear systems, differential equations, and many 

other types of scientific computations. 
 

RUNNING MATLAB 

MATLAB supports almost every computational platform.MATLAB for WINDOWS is 

started by clicking on the MATLAB icon. The command window is launched, and after 

some messages such as intro, demo, help, info, and others, the prompt >>’’ is displayed. 

The program is in an interactive command mode. If an expression with correct syntax is 

entered at the prompt in the command window, it is processed immediately and the result 

is displayed on the screen. If an expression requires more than one line, the last character 

of the previous line must contain three dots …’’.Characters following the percent sign are 

ignored. The command clear erases all variables in the command window. 

In MATLAB, elements enclosed by brackets and separated by semicolons generate a 

column vector. 

For example, the statement 

X = [ 2; -4; 8] results in 
 

X = 

2 

-4 

8 

If elements are separated by blanks or commas, a row vector is produced. 

ELEMENTARY MATRIX OPERATIONS 

MATLAB has two different types of arithmetic operations. Matrix arithmetic operations are 

defined by the rules of linear algebra. Array arithmetic operations are carried out element- 

by-element. 

In MATLAB, a matrix is created with a rectangular array of numbers surrounded by 

brackets. The elements in each row are separated by blanks or commas. A semicolon must 

be used to indicate the end of a row. Matrix elements can be any MATLAB 

expression. The statement 

A = [6 1 2; -1 8 3; 2 4 9] 

results in the output 

A= 

 
6 1 2 

-1 8 3 

2 4 9 

 

If a semicolon is not used, each row must be entered in a separate line as shown below. 
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A = 
 

Matrices of the same dimension can be added or subtracted. Two matrices, A and B, can 

be multiplied together to form the product AB if they are conformable. Two symbols are 

used for nonsingular matrix division. 
 

A\B is equivalent to A
-1

B and A/B is equivalent to AB
-1

 

 
1.7 ELEMENTARY MATRIX OPERATIONS 11 

 

Example 1.1 
 

For the matrix equation below, AX = B, determine the vector X. 
 

 

 
 

= 

 

 

 

The following statements 
 

A = [4 -2 -10;   2 10 -12; -4 -6   16]; 

B = [-10; 32; -16]; 

X = A\B 
 

result in the output 
 

X= 

2.0000 

4.0000 

1.0000 
 

In addition to the built-in functions, numerous mathematical functions are avail- able in 

the form of M-files. 

 

Example 1.2 

 

Use the inv function to determine the inverse of matrix A in Example 1.1 and then 

determine X.The following statements 

A= [4 -2 -10; 2 10 -12; -4 -6 16]; 

 

B= [-10; 32; -16]; 

C=inv (A) 
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X = C*B 

 
 

result in the output 

C= 

 

 

X= 

2.0000 

4.0000 

1.0000 
 

Examble1.3 

EIGEN VALUES 

If A is an n x n matrix the ‘n’ numbers λ that satisfy Ax = λ x are the eigenvalues of 

‘A’ They are found using eig(A), Which returns the eigenvalues is a column vector 

Eigenvalues and eigenvectors can be obtained with a double assignment statement 

[X,D] =eig(A). The diagonal elements of D are the eigenvalues and the columns of X 

are the corresponding eigenvectors such that AX = XD. 

 

Find the eigenvalues and the eigenvectors of the matrix A given by 

 

 

A=  

A= [0 1 -1; -6 -11 6; -6 -11 5]; 

[X, D] = eig (A) 

The eigenvaluves and the eigenvectors are obtained as follows 
 
 
 
 
 
 

- 

2.2000 2.3000 3.1000 

0.4000 0.6000 0.7000 

0.7000 0.8000 1.1000 

 

X=  

 
-0.7071 0.2182 -0.0921 

 0.0000 0.4364 -0.5523 
 0.7071 0.8729 -0.8285 
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D=  

 -1 0 0 
 0 -2 0 
 0 0 -3 

 
 
 
 

Exercise: 1 

 
Find the solution to 
2x1 + x2 - 4x3 + 6x4 + 3x5 - 2x6 = 16 

X1 + 2x2 + 3x3 + 5x4 - 2x5 = -7 

x1 - 2x2 - 5x3 + 3x4 + 2x5 + x6 =  1 

4x1 + 3x2 - 2x3 + 2x4 + x6 = -1 

3x1 + x2 - x3 + 4x4 + 3x5 + 6x6 = -11 

5x1 + 2x2 - 2x3 + 3x4 + x5 + x6 = 5 

using the matrix inverse and left and right division 

 

 

 

 

 
 

Exercise: 2 

 
Given the matrix A=[7 -6 -4 1; -5 1 0 -2; 10 11 7 -3; 19 9 7 1], compute the inverse of 

A. 

Use the resulting matrix to obtain the solution of the matrix equation Ax=b for the 

different choices of b given below 

(a) [-32;-18;120;153] 

(b) [11;-11;-1;20] 

(c) [-5;-1;8;10] 

(d) [26;-21;43;81] 

Employ MatLab for the necessary computations 
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AutoCAD DRAWINGS FOR PRACTICE 
(RECORD WORK NOT REQUIRED) 

 

 

 
 

Ex. No: 1 
 
 

 

Fig 1.1 
 

Hints for Practice Fig 1.1 
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Fig 1.2 
 

 

 

Hints for Practice Fig 1.2 
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Fig 1.3 
 

Hints for Practice Fig 1.3 
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Ex. No: 2 
 

 

 
 

Fig 2.1 
 

 

 

 

 

 

 

 

Fig 2.2 
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Fig 2.3 
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Ex. No: 3 

 

Fig 3.1 
 

20 
 

 

 

 

 

 
 

 

 

 

 

 

R20 
 

 

 

 

 

 

 
 

 

 

 

 

Fig 3.2 

10 

R20 

R15 
Ø16 

R10 

R45 

90° 
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Fig 3.3 
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Ex. No: 4 
 

 

 

 
 

Fig 4.1 
 

 

Fig 4.2 
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Fig 4.3 
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Ex. No: 5 
 
 

 

Fig 5.1 
 

 

 

Fig 5.2 Fig 5.3 
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Fig 5.4 
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Ex. No: 6.1 FLANGED COUPLING 

 
Draw the Half sectional view (Fig 6.1) of the given FLANGED COUPLING 

 

PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 
3. Use F3 key (OSNAP command). From the dialog box select end point, midpoint etc. 

4. By using F8 key, the ortho is ON. 

5. From the UCS (User Co-ordinate System) dialog box select required view. 
6. Draw the different parts of flange coupling by using draw and edit commands. 

7. By using move command, assemble all parts. 

8. By using hatch command, the required portion of drawing is hatched. 

 
 

 
Fig 6.1 
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Ex. No: 6.1 FLANGED COUPLING 

 
Draw the Half sectional view (Fig 6.1) of the given FLANGED COUPLING 

 

PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 

3. Use F3 key (OSNAP command). From the dialog box select end point, midpoint etc. 
4. By using F8 key, the ortho is ON. 
5. From the UCS (User Co-ordinate System) dialog box select required view. 

6. Draw the different parts of flange coupling by using draw and edit commands. 

7. By using move command, assemble all parts. 
8. By using hatch command, the required portion of drawing is hatched. 

 

Fig 6.1 
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Ex. No: 7.1 SCREW JACK 

 

Draw the Half Sectional Front view (Fig 7.1) of the SCREW JACK 

 
PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 
3. Use F3 key (OSNAP command). From the dialog box select end point, midpoint etc. 

4. By using F8 key, the ortho is ON. 

5. From the UCS (User Co-ordinate System) dialog box select required view. 

6. Draw the different parts of Screw Jack by using draw and edit commands. 

7. By using move command, assemble all parts. 
8. By using hatch command, the required portion of drawing is hatched. 

 

 

Fig 7.1 
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Fig 7.1 
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Ex. No: 7.2 PLUMMER BLOCK 

 
Draw the Half Sectional Front view (Fig 7.2) of the PLUMMER BLOCK 

 
PROCEDURE: 

1. Open the AutoCAD window. 
2. Set the required limits and grids. 

3. Use F3 key (OSNAP command), from the dialog box 
Select end point, midpoint etc. 

4. By using F8 key, the ortho is ON. 
5. From the UCS (User Co-ordinate System) dialog box 

Select required view. 

6. Draw the different parts of Plummer block by using 

Draw and edit commands. 

7. By using move command, assemble all parts. 
8. By using hatch command, the required portion of 

Drawing is hatched. 
 

 

 
 

 

Fig 7.2 
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Fig 7.2 
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